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Introduc�on
Ally reports have the poten�al
to bring up informa�on about a
wide array of issues, depending
on the type of item (Word
document, image file, html file,
etc.). In many cases, when you
click on individual items to get
detailed informa�on you will
see an annotated image,
poin�ng out the issue, what it
means, and how to fix it.
However, this is not always the
case. In par�cular Ally does not
have full guidance on all of the
issues it can find within html
files. 

Example of an Ally report overview

The informa�on in this resource aims to bridge any gaps between an Ally report and your full understanding
of an issue. The next few pages deal with files of par�cular types:

Word documents
PDFs
PowerPoint presenta�ons
Image files
HTML files
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Issue Explana�on How to Fix

The document
does not have
any headers

This document doesn't
contain any marked-up
headings. Headings are
important as they provide
structure to a document,
especially those that consist
of many pages. When
headers are properly and
consistently used, the
document becomes much
easier to understand and
navigate for all users.
Sighted users rely on text
size and bold to iden�fy
different sec�ons, properly
coding those as headings
allows users of assis�ve
technology to do the same. 

In Word, select the text that should become a heading
(document �tle, sec�on �tles).

Under the Home tab in the Styles group, click the
appropriate heading level. If you don't see the heading
level you are looking for, click the arrows to browse the
full list of preset styles.

Always choose "Heading 1" for the �tle of your document,
"Heading 2" for sec�on headings, "Heading 3" for
subsec�on headings, etc. "Normal" is used for paragraph
text.

Repeat these steps for all the text that should become
headings.

The headings in
this document
do not begin at
level 1

The headings in this
document don't begin
with heading 1 and
therefore don't follow a
logical order. Having the
main heading at the
beginning of the document
will provide a more logical
structure and will make the
document much easier to
understand and navigate for
all users.

For standard documents,
the �tle of the document
should be Heading 1.

Open the Word document and change the �tle of the
document to heading level 1. Make sure sec�on �tles
begin at heading level 2, with sub-sec�ons at heading
level 3.

Video Demo:Fix Minor Heading Issues  (Links to an
external site.) (h�ps://youtu.be/-hrAjK2rlRs)

Word document errors

https://youtu.be/-hrAjK2rlRs
https://youtu.be/-hrAjK2rlRs
https://youtu.be/-hrAjK2rlRs
https://youtu.be/-hrAjK2rlRs
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The headings in
this document
do not follow a
logical structure

Headings should be
hierarchical, star�ng at
heading level 1 for the �tle
of the document, then
heading level 2 for the
sec�ons of the document,
then heading level 3 for
subsec�ons, and so on.
Heading levels should not be
skipped.

In Word, go to View and open the Naviga�on Pane. This
will allow you to get a quick look at the heading
structure. Check to see that the correct sec�ons are
nested under their parent sec�on.

Click through the headings of the document to uncover
any skipped heading levels (e.g. going from heading level
2 to heading level 4) - the accessibility checker in Word
will call out skipped headings.

Ex:
Heading 1
-Heading 2
--Heading 3
--Heading 3
-Heading 2
---Heading 4 (should be H3)
--Heading 3

Video Demo:Fix Minor Heading Issues  (Links to an
external site.) (h�ps://youtu.be/-hrAjK2rlRs)

This document
has contrast
issues

This document contains text
with low contrast between
the text and its background.
This can cause the text to be
difficult to read, especially
for those with low vision,
poor eyesight or color
blindness.

Change any light font colors to a darker shade (if using
headings, modify the style to save �me - open the Styles
pane, right click on the heading level and select modify,
adjust the color in the ).

Check your tables - change the color pale�e used for
tables to increase contrast in header rows.

Video Demo:Improve Document Contrast (Links to an
external site.) (h�ps://youtu.be/kCIIzLgG3r0)
(h�ps://youtu.be/kCIIzLgG3r0)

Use a tool like the Document Accessibility Toolbar to
scan for contrast issues
(h�ps://www.visionaustralia.org/dat)

The document
does not have a
language set

The document does not
specify the language in
which it's been created.
Certain technologies, such
as screen readers, rely on
the specified language to
determine how to 
pronounce the document
text.

Click Review > Language > Set Proofing Language.

Video demo:Fix Document Language (Links to an
external site.) (h�ps://youtu.be/jWZQCcj5CnQ)

https://youtu.be/-hrAjK2rlRs
https://youtu.be/-hrAjK2rlRs
https://youtu.be/-hrAjK2rlRs
https://youtu.be/-hrAjK2rlRs
https://youtu.be/kCIIzLgG3r0
https://youtu.be/kCIIzLgG3r0
https://youtu.be/kCIIzLgG3r0
https://youtu.be/kCIIzLgG3r0
https://youtu.be/kCIIzLgG3r0
https://youtu.be/jWZQCcj5CnQ
https://youtu.be/jWZQCcj5CnQ
https://youtu.be/jWZQCcj5CnQ
https://youtu.be/jWZQCcj5CnQ
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The document
does not have
the correct
language set

This document does not
specify the correct language
in which it's been created.
Certain technologies, such
as screen readers, rely on
the correct language being
specified to determine how
to  pronounce the document
text.

Click Review > Language > Set Proofing Language.

Video demo:Fix Document Language (Links to an
external site.) (h�ps://youtu.be/jWZQCcj5CnQ)

The document's
heading
structure goes
beyond six levels

The headings in this
document goes beyond six
levels. Most technologies,
including screen readers and
other assis�ve technology,
are limited to six levels of
headings. Going above this
can cause these headings to
not be represented or read
appropriately.

In Word, review your heading structure by going to the
View tab and opening the Naviga�on pane. See if you can
reduce the number of sec�ons by using bulleted,
numbered, or outlined lists instead.

Make sure your headings are labelled hierarchically
(heading 3s are nested under heading 2s) and
you're not assigning them chronologically (heading 1, then
2, then 3, then 4, 5, etc.).

The document
has images
without
alterna�ve
descrip�ons

This document contains
images that don't have a
descrip�on or alterna�ve
text. People with screen
readers or other assis�ve
devices rely on these
descrip�ons to understand
the image content and
purpose. Alt text will also
display if an image doesn't
load - benefi�ng everyone.

Right click on the image (Sh� + F10), select Format
Picture, under Proper�es and Layout open the Alt Text
pane, enter text in the Descrip�on field (not the Title field)

The document
has tables that
don't have any
headers

This document contains
tables that don't have or
properly specify a header
structure. People with
screen readers or other
assis�ve devices rely on a
correct heading structure to
help them navigate the table
and match the headings to
the data cell.

Click on the table row that contains the headers. Right
click (Shi� + F10), open Table Proper�es. Under Row tab,
select "Repeat as header row at the top of each page."
Uncheck "Allow row to break across pages."

Make sure you're not using tables for layout purposes. If
your table doesn't need headings (the top row or first
column doesn't serve as a label for the data/info
underneath/beside) then do not use a table. 

Note: Alt text - tables can also contain alt text, you can
either add explanatory alt text to your table, or mark it
as decora�ve and describe it in the body text.

https://youtu.be/jWZQCcj5CnQ
https://youtu.be/jWZQCcj5CnQ
https://youtu.be/jWZQCcj5CnQ
https://youtu.be/jWZQCcj5CnQ
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The document is
malformed

These documents are
malformed and therefore
cannot be opened and
viewed by many or even
most people. While some
technologies might be able
to deal with some
malformed documents,
there's no guarantee that
everyone will be able to
view the document or that
the forma�ng and content
will be as intended.

If you do not have the original source document, you may
not be able to fix this problem.

If you can open the file on your computer, paste the
content in a new document and try to save and re-upload
the document.
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PDF errors and fixes

Issue Explana�on How to Fix

The document is
scanned but not
OCRed

These documents are either
en�rely scanned or contain pages
that are scanned. This means it's
an image of a document and the
text cannot be accessed by
assis�ve technology. Scanned
documents, especially those of
poor quality or those containing
handwri�ng, can be difficult to
read for everyone. They also have
other usability issues such as not
being able to search inside the
document.

Acrobat Pro will convert the scanned image to
text. In Acrobat Pro, under Tools, select Enhance
Scan. Make sure Recognize text is selected. The
higher quality the scan, the more accurate the
conversion will be.

If you do not have Acrobat Pro, use Ally. Next to
the file, click on the small arrow poin�ng down
to the right of the edi�ng wheel. Select
Alterna�ve formats. You can download an OCRed
PDF. If you want to go one step further and add
headings, paste the text from the PDF into a
Word document and add headings.

This PDF contains
images that are
missing an
alterna�ve
descrip�on

An alterna�ve descrip�on is a
textual alterna�ve for an image. It
allows students with visual
impairments to perceive the
image. Alterna�ve descrip�ons
should be added to all images,
including those embedded within
PDF, Word, PowerPoint and other
documents.

If you have the source document, use Word to
add alterna�ve text to the document images.
Right click on the image (Sh� + F10), select
Format Picture, under Proper�es and Layout
open the Alt Text pane, enter text in the
Descrip�on field (not the Title field).

If you do not have the source document, you will
need Acrobat Pro to add alt text to the images. In
Acrobat Pro, go to Tools. Select Accessibility.
From the Accessibility toolbar you can select "set
alternate text". You will be taken from image to
image and can add alt text or mark the image as
decora�ve.

This PDF has no �tle PDF �tles are used as the
document �tle for a PDF window
or tab, making it easier to navigate
to the PDF and understand the
purpose of the PDF. O�en the
default is the file name which may
not be meaningful/descrip�ve. 

In your PDF viewer, Files > Proper�es > type a
meanfingul/descrip�ve �tle in the Title field



Anthology Ally - Instructor report errors and fixes

8/18

This PDF has
contrast issues

Low contrast can make documents
difficult to read.

If you have the source document in Word, start
there by changing the font color to improve
contrast.

If do not have the source document but you
have Adobe Acrobat Pro, use the Enhance Scans
tool to improve contrast. Tools > Enhance Scans.

If you do not have Adobe Acrobat Pro, you may
be able to change the contrast with a program
like Photoshop.

The headings in this
PDF do not follow a
logical structure
***and you have
the original source
document in Word

Headings should be hierarchical,
star�ng at heading level 1 for the
�tle of the document, then
heading level 2 for the sec�ons of
the document. Heading levels
should not be skipped.

If you have the source document, use Word to fix
the headings. Headings should be hierarchical,
star�ng at heading level 1 for the �tle of the
document, then heading level 2 for the sec�ons
of the document. Heading levels should not be
skipped.

In Word, Click through the headings of the
document to uncover any skipped heading levels
(e.g. going from heading level 2 to heading level
4). Ex:

Heading 1
-Heading 2
--Heading 3
--Heading 3
-Heading 2
---Heading 4 (change to H3)
--Heading 3
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The headings in this
PDF do not follow a
logical structure
***and you do not
have the source
document

Headings should be hierarchical,
star�ng at heading level 1 for the
�tle of the document, then
heading level 2 for the sec�ons of
the document. Heading levels
should not be skipped.

If you do not have the source file, you will need
Acrobat Pro (and not Reader), to alter the
document tags. Open the tags pane (View >
Show/Hide > Naviga�on > Tags). Review the tag
tree and check the heading levels (H1 = heading
level 1, H2 = heading level 2, etc.). You can
double click on the tag to change the heading.

In Acrobat Pro, double click on the heading tag
to change it.
<H1>
<P>
<H2>
<P>
<H4> (change to H3)
<P>

(Normal body text should be tagged with <P>)

This PDF does not
have a language set

In your PDF viewer, Files > Proper�es >
Advanced > select language

The document is
untagged

These PDF documents are not
tagged. PDF tags are hidden labels
that clarify the structure of the
document and define what's a
heading, paragraph, table, list, etc.
Without these tags, PDF
documents are essen�ally just a
bag of difficult to dis�nguish
words that can be really hard to
navigate and understand for
people with screen readers or
other assis�ve devices.

If you have the source document, it is much
easier to add headings in Word and save the
document as a PDF.

Otherwise, you will need Adobe Acrobat Pro to
fix this problem.

Open the Accessibility tool (Tools >
Accessibility). Select "auto tag document".
Review the tags to ensure they are in logical
order. Always choose "Heading 1" (<H1>) for the
document �tle, "Heading 2" (<H2>) for sec�on
headings, "Heading 3" (<H3>) for subsec�on
headings, etc. "Paragraph" (<P>) is used for
paragraph text.

If there are errors in the tags, double click on
them to change the heading level.
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The document is
scanned and OCRed

These scanned documents have
been OCRed (Op�cal Character
Recogni�on). Digi�zing printed
text through OCR allows users and
assis�ve technologies to extract
and search text inside the
document. OCRed documents,
especially those of poor quality,
can s�ll be difficult to read for
everyone.

To improve the readability of the document, it is
recommended that you add tags. Tags act like
headings, allowing users to navigate from
sec�on to sec�on.

If you have the source document, it is much
easier to add headings in Word and save the
document as a PDF.

Otherwise, you will need Adobe Acrobat Pro to
fix this problem.

Open the Accessibility tool (Tools >
Accessibility). Select "auto tag document".
Review the tags to ensure they are in logical
order. Always choose "Heading 1" (<H1>) for the
document �tle, "Heading 2" (<H2>) for sec�on
headings, "Heading 3" (<H3>) for subsec�on
headings, etc. "Paragraph" (<P>) is used for
paragraph text.

If there are errors in the tags, double click on
them to change the heading level.
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PPT errors and fixes

Issue Explana�on How to Fix

This presenta�on
has contrast issues

This document contains text with low contrast
between the text and its background. This can
cause the text to be difficult to read, especially for
those with low vision, poor eyesight or colour
blindness.

Change the slide theme in
order to improve contrast
between the text and
background.

This presenta�on
contains images that
are missing an
alterna�ve
descrip�on

An alterna�ve descrip�on is a textual alterna�ve for
an image. It makes it easier to connect the image to
its context and allows students with visual
impairments to perceive the image. Alterna�ve
descrip�ons should be added to all images,
including those embedded within PDF, Word,
PowerPoint and other documents.

Right click on the image (Sh� +
F10), select Format Picture,
under Proper�es and Layout
open the Alt Text pane, enter
text in the Descrip�on field (not
the Title field)
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Image errors and fixes

Issue Explana�on How to Fix

The image
does not
have a
descrip�on

An image descrip�on, some�mes
referred to as 'alterna�ve descrip�on'
or 'alt text', is a textual alterna�ve for
an image. It makes it easier to
connect the image to its context and
allows students with visual
impairments to perceive the image.
Descrip�ons should be brief and
convey the full meaning of the image.
They should not be the same as the
file name as this is o�en not
descrip�ve enough.

An image descrip�on should provide a textual
alterna�ve to the image so that people with a
visual impairment can get an equivalent
experience. Descrip�ons also make it easier for all
students to connect the image with the context.
Different tools offer different ways of adding alt
text (e.g. right-clicking in Word, or when adding an
image to a Brightspace item you will be prompted
to add alt text, or specify that the image is
decora�ve - see not below).

*Note: if an image is purely decora�ve, or is
described in the text, it can be marked as
decora�ve and does not require alt text.

The image
can induce
seizures

These animated images contain
flashing or contras�ng lights or
pa�erns that can lead to seizures for
people that suffer from
photosensi�ve epilepsy, which is a
very serious and poten�ally life-
threatening condi�on. Animated
images with these characteris�cs can
be generally unpleasant to look at,
even for those not prone to seizures.

Find an alterna�ve image. Do not use this image.

The image
has text that
is not part of
the
alterna�ve
descrip�on

The image contains text that is not
represented in the descrip�on or
alterna�ve text of the image. People
with screen readers or other
assis�ve devices rely on these
descrip�ons to understand the
image content and purpose and will
not be able to read any text in the
image that's not part of the
descrip�on.

If this is an image ac�ng as text (like a banner
graphic), replace it with actual text.

If this is a screenshot that contains text
components, just make sure the alt text is
descrip�ve enough to capture the nature of the
screenshot. In such cases, this is not a problem that
needs to be fixed - you just need to be smarter than
the machine (Ally) at determining whether or not it
is a problem.
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The image
has contrast
issues

The image contains text with low
contrast between the text and its
background. This can cause the text
to be difficult to read, especially for
those with low vision, poor eyesight
or colour blindness.

Upload the image into a program like Photoshop
to increase the contrast. 

If you do not have a fancy image edi�ng program,
use PPT. Upload the image to a PPT slide. Under
the Picture Format tab, you can adjust the
contrast of the image in the Correc�ons
dropdown menu. Right click on the image to save
it as a picture.

Video Demo:Increase Image Contrast (Links to an
external site.) (h�ps://youtu.be/7tQHCjcC-xI)

There is no way to know if the contrast has been
improved enough to sa�sfy Ally's evalua�on, but
use your best judgment to do what you can.

https://youtu.be/7tQHCjcC-xI
https://youtu.be/7tQHCjcC-xI
https://youtu.be/7tQHCjcC-xI
https://youtu.be/7tQHCjcC-xI
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HTML errors & fixes 

Issue Explana�on How to Fix

The HTML
content has
contrast issues

The HTML content contains text
with low contrast between the text
and its background. This can cause
the text to be difficult to read,
especially for those with low vision,
poor eyesight or colour blindness.

Change the color of the font and/or background color.
User WebAIM's color contrast checker
(h�ps://webaim.org/resources/contrastchecker/) to
find an appropriate color contrast.

You can also use the Brightspace Accessibility checker
from the HTML Editor to select new colors while in
Edit mode.

The HTML
content has
images
without
alterna�ve
descrip�ons

The HTML content contains images
that don't have a descrip�on or
alterna�ve text. People with screen
readers or other assis�ve devices
rely on these descrip�ons to
understand the image content and
purpose. Having a clear descrip�on
for an image can help everyone
be�er understand the content of
the image and how it relates to the
context.

Click on the image. Go to the Image Op�ons icon from
the HTML Editor. Type the alt text into the alt text
field.

The HTML's
heading
structure does
not start at the
right level

The headings in the HTML content
don't begin with the main heading
and therefore don't follow a logical
order. Having the main heading at
the beginning of the document will
provide a more logical structure
and will make the document much
easier to understand and navigate
for all users.

On a Brightspace page, the page �tle is Heading 1.
Sec�on �tles should begin at heading level 2. Sub-
sec�ons should be heading level 3.

The HTML
content has
tables that
don't have any
headers

The HTML content contains tables
that don't have or properly specify
a header structure. People with
screen readers or other assis�ve
devices rely on a seman�cally
meaningful and correct heading
structure to help them navigate the
table and understand the meaning
of every cell, but it can be
beneficial to everyone to have a
clear structure in the table.

Highlight the cells of the header row (or column).

From the table menu in the rich content editor, select
"Cell", then "cell proper�es".

Select "header cells" from the Cell type dropdown
menu.

Select "columns" (if the headings are by column as
below. If it's arranged by row, select rows. If you do
both, select both op�ons.) from the scope dropdown
menu. Click "Ok".
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The HTML
content has
empty
headings

The HTML content contain
headings with no content. This can
cause poten�ally confusing
contentless alerts to screen reader
users.

It is easy to accidentally mark the line before or a�er a
heading as a heading. Check your page to make sure
any blank lines are normal text and not a heading.

The HTML
content does
not have any
headers

The HTML content doesn't contain
any marked-up headings. Headings
are important as they provide
structure to a page. When headers
are properly and consistently used,
the page becomes much easier to
understand and navigate for all
users, and provides addi�onal
benefits such as the ability to
automa�cally generate a Table of
Contents.

For longer pages with mul�ple sec�ons, adding
headings will allow a user to navigate by sec�on.
Sighted users can scan for sec�on �tles, which are
usually bold or larger font.

To add headings, in edit mode, navigate your cursor to
the sec�on �tle. In the HTML Editor click on the
dropdown menu next to the font size (it is in the top
le� of the editor and probably reads "Paragraph" to
signify it is currently set to paragraph text). Select the
appropriate heading level for that sec�on �tle.

On a Brightspace page, the page �tle is Heading 1.
Sec�on �tles should begin at heading level 2. Sub-
sec�ons should be heading level 3.

The HTML
content does
not have an
appropriate
heading
structure

The HTML content contains
headings that don't follow a logical
order. All headings should follow a
sequen�al and descending order.
Headings are important as they
provide structure to a page,
especially longer ones. Well-
structured and logical headings will
make the page much easier to
understand and navigate for all
users.

On a Brightspace page, the page �tle is Heading 1.
Sec�on �tles should begin at heading level 2. Sub-
sec�ons should be heading level 3.

The HTML
content
contains links
without
discernible
text

The HTML content contains links
with text that is not discernible by
a screen reader or is not focusable.
People with assis�ve technologies
would be unable to understand the
link or navigate to it.

This is a common problem that usually results from
someone dele�ng link text, but not fully removing
the hyperlink. You can usually track down the link by
looking for an external link icon that is not
associated with any text or falls before hyperlinked
text. 

To remove it, delete out the blank space, or look in
the HTML code and remove the link. 
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The HTML
content has
form elements
without a label

The HTML content contains form
elements such as input boxes,
checkboxes, dropdowns, etc. that
are not labelled. People with
assis�ve technologies o�en require
the form elements to be explicitly
labeled to understand the purpose
of each field and to use the form
effec�vely.

The HTML
content has
embedded
objects
without
alterna�ve
descrip�ons

The HTML content contains
embedded objects that don't have
a descrip�on or alterna�ve text.
People with screen readers or
other assis�ve devices rely on
these descrip�ons to understand
the purpose and content of
embedded objects.

The HTML
content does
not have a
language set

The HTML content does not specify
the language in which they have
been created. Certain technologies,
such as screen readers, rely on the
specified language to determine
how to process the content or
pronounce the text inside of the
page.

The HTML
content is
missing a �tle

The HTML content is missing a �tle.
HTML page �tles are used as the
�tle for a browser window or tab,
making it easier to navigate to the
tab and understand the purpose of
the tab.

The HTML
content has
malformed
lists

The list (<ul> or <ol>) elements in
the HTML content contain
inappropriate child elements. This
can cause screen readers to read
out the defini�on lists incorrectly.
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The HTML
content has
links or
bu�ons with
redundant text

The HTML content contains
bu�ons or links with text that is
repeated in the containing image's
alterna�ve descrip�on.
Screenreaders and other assis�ve
devices would therefore read this
text twice, which is redundant and
poten�ally confusing.

The HTML
content has
malformed
defini�on lists

The definition list (<dl>) elements in
the HTML content contain
inappropriate child elements. This
can cause screen readers to read
out the definition lists incorrectly.
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Source: 
h�ps://sbctc.instructure.com/courses/1578604/pages/ally-remedia�on-cheatsheet
(h�ps://sbctc.instructure.com/courses/1578604/pages/ally-remedia�on-cheatsheet) (content is offered under
a CC A�ribu�on (CC BY 4.0) (h�ps://crea�vecommons.org/licenses/by/4.0/) license).  

https://sbctc.instructure.com/courses/1578604/pages/ally-remediation-cheatsheet
https://sbctc.instructure.com/courses/1578604/pages/ally-remediation-cheatsheet
https://creativecommons.org/licenses/by/4.0/
https://creativecommons.org/licenses/by/4.0/



