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extended list of TestGen’s features, please click on the ‘Help” option from the main menu of the program.  
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Quick Reference User Guide for TestGen 
 

1. Key Terms and Reminders 

 
a. Testbank vs. Test 

i)  Testbank – the entire collection of questions in an electronic file (assessment content) 

distributed by publishers in conjunction with a book or course. Designated by the 

extension .bok.  

ii)  Test – the exam for the student. Created from the testbank. Designated by the 

extension .tst.  

 

b. Question Types 

i) Multiple Choice – can have one or more correct answers 

ii) True-False 

iii) Short Answer – has less than 20 characters in the correct response 

iv) Essay 

v) Matching 

vi) Bimodal – a multiple choice question that can be used either as Multiple Choice or 

Short Answer – the choice is up to the user. 

 

c. Files on hard drive for autosave 

i) All data files must be on hard drive. The program autosaves and will not run data 

from a CD-ROM. It is possible to open files in TestGen saved to a flash drive, however, 

the best practice is to store testbanks and test files to a hard drive.  

 

d. Left Pane vs. Right Pane 

i) Left pane – gives you the list of testbanks added to your library.  

ii) Right pane is where you create or edit tests and testbanks.  
 

2. Adding and Deleting a testbank in the TestGen Library  

 
Note: If you have not yet obtained a testbank associated with the textbook or instructional 

materials you are using, please contact your publisher or other resource for instructions to 

download or order a CD containing the appropriate file. Due to the volume of data in 

testbank files they will typically be provided to you in a compressed or zip file format. 

Before you can add it to your TestGen library, you will need to copy or move the compressed 

testbank file onto your local hard drive. Then extract the testbank which will have a .bok file 

extension.  
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     a.   Downloading and saving testbank (.bok) files 

 i) From an instructor resource site, CD provided by your publisher or other appropriate 

 source, locate the testbank file (compressed or zip file format) for your course.  

 ii) Download and save a copy of the compressed testbank file onto your local hard drive. 

 iii) Extract the testbank which will have a .bok file extension and save the uncompressed  

 file to either the default TestGen “testbanks” folder on your hard drive or to a custom 

 folder of your choice.  

  

  Note: For your convenience, a default “testbanks” folder is created as part of the   

  TestGen installation. The location path for those using Windows operating systems is  

  “Documents\TestGen\TestGen\Testbanks". The location path for those using Mac  

  operating systems is "Documents/TestGen/Testbanks".  

 

 iv) If you choose to save your testbank file(s) to a different location other than the  

 default folder, be sure to record the folder name and path for reference when browsing 

 for testbanks to add to the TestGen library.  

 v) It is not recommended to save files to your system “desktop’ as files can be easily  

 deleted or moved and are not always included in system data backups.  

 

b.  Add a single testbank to the TestGen Library by browsing 

i) After TestGen is installed, you can add testbanks one-at-a-time by opening the File 

menu or right-clicking in the Testbank Library and selecting "Add Testbank to Library". 

Use the browse dialog to locate and select a TestGen testbank (.bok) file on your 

computer and click “Open” to display the testbank's title in the Testbank Library. 

 

c.  Add all testbanks 

i)  After TestGen is installed, if you have multiple TestGen testbanks on your computer, 

but not yet listed in the Testbank Library, you can select "Locate Testbanks" on the File 

menu. When you click OK, TestGen will search your computer's hard drive to find all the 

TestGen testbank (.bok) files and add their titles to the Testbank Library. 

 

d.  Moving location of testbank files 
ii)  The titles listed in the Testbank Library are simply links to the existing testbank 

locations.  

iii) If you change the location or delete the testbank file (.bok) from the location you 

saved it to on your hard drive, TestGen will no longer be able to find it and you will need 

to add it to the library again.   

 

e.  Deleting Testbanks from the Testbank Library 
i)   When you want to remove a testbank from the list of testbanks in the Testbank   

Library, select one or more testbank names from the list, and then do one of the       

following: 
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 -  Click the Delete icon on the Standard toolbar. 

 -  Select "Delete" from the Edit menu. 

 -  Press the Delete key on your computer keyboard. 

-  Right-click on a testbank name in the list and choose "Delete" from the    

   contextual menu. 

ii)   After you choose Delete, confirm that you want to remove the testbank from the                    

Testbank Library. 

iii)  Deleting a testbank name from the list of testbanks in the Testbank Library does  

NOT delete the testbank file from your computer; it simply removes the library link. 

iv)  Only complete testbanks can be removed from the Testbank Library. You cannot  

delete chapters, sections, or questions from a testbank in the Testbank Library. If you 

need to modify the contents of a testbank, enable testbank editing and make changes to 

the testbank in the testbank editing window.  

 

3. Creating a Test 
 

a. Open a New Test 

i) Go to the File menu and choose New Test or click on the icon to the left of Paper Test 

or Web Test in the right pane. 

 

b. Test options 

i) Go to the Tools menu. Select Preferences. Select Test Options. 

ii) From Test Options you can set the way the answers appear, the styles used, and the 

descriptors to be displayed from the various available tabs.  

 Note: Be careful to not check the correct answer descriptor when printing a test

 for students as the correct answer will then be displayed next to each question. 

 Correct answers are marked with a green circle with a checkmark inside. These

 will not show up on the printed test . 

iii) TestGen supplies a generic question type header (instructions for a given set of 

questions in like format) for each of the six main question types: multiple choice, 

true/false, short answer, essay, matching, and vocabulary. They are most useful when a 

test is sorted by question type. Depending on your application of the question types, you 

may want to edit or not display the generic headers.  

iv)  To modify the wording of any of the question type headers, select "Question Type 

Headers" from the Tools menu. If question type headers are already displayed on the test, 

you can also doubleclick any of the headers to open the Edit Question Type Headings 

dialog.  
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v) To turn the question type headers on or off, go to the Questions tab and select "Do not 

display questions type headers” or Display question type headers". If you want your 

selection to apply to both your current test and to all the tests you create in the future, be 

sure to press the "Set as default" button at the bottom of the Test Options dialog box 

before hitting ‘OK’.  

vi) Save your test by going to the File menu, choose Save Test As and save with a name 

and location as you would any other data file. 

 

c. To add individual questions to an open test file 

i)  Use the expand button  by the testbank name in the left window to show list of 

chapters.  

ii) Expand the chapter of your choice. 

iii) Select a question, hold down on the left mouse button and drag the question over to 

the test. 

iv) You can use the CTRL key to select multiple questions at once. 

v) You can also drag over an entire chapter or other section heading, at once – do not 

expand the heading, just drag the heading name over onto the test. 
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d. To add questions randomly to an open test 

i) Select the chapters from which you want to have questions. You can select multiple 

chapters by holding down the CTRL or SHIFT key.  

ii) Click on the Choose Multiple button at the bottom of the left window.  

iii) A dialog screen will appear asking for a number of questions. The program will pull 

the same number of questions from each chapter. 

 

 
 

iv) Click Add to test and the questions will be transferred. 

 

e. Editing existing questions  

i) To edit a question, click on the text. A box becomes visible around the question. You 

can edit just as you would in a word processing program. The same applies for any answer 

choice. 
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f. Adding new questions to the test 

i) To add a question, select the question after which you wish to add a new question (left 

click the item number so that the entire question is highlighted). 

 

 
 

ii) From the Insert menu choose Question. Then choose the question type. A blank 

question will appear. Select the box for the question or the answer and type in the text 

just as you would in a word processor. 

 

 
 

iii) Additional answer choices can be added to a multiple choice question by highlighting 

the entire question. Go to the Insert menu and choose Blank Answer Choice. 

 

g. Deleting questions 

i) To delete a question, select the question, right click and choose delete. This is a 

permanent function – the program autosaves. If you want to undo a deletion, you must 

undo before performing other actions. 

 

h. Organize the questions in the test 
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i) You can scramble the order of questions and/or answer choices by clicking on the 

‘scramble’ icon on the toolbar .  

ii) Click on this option and select either Scramble All Questions (this keeps answer 

choices in the same order within a question) or Scramble All Questions and All Answer 

Choices. This scrambles the questions and then scrambles the answer choices within each 

question. 

iii) You can organize the items on a test in various ways by clicking on the ‘sort’ icon on 

the toolbar . 

iv) You can sort by type or by descriptor – sorting by descriptor only works if that 

descriptor is available in the testbank.  

 

 

 
 

4. Printing a Test 
 

a. Answer key 

i) To print an answer key go to the Tools menu. Select Preferences. Select Test Option 

and click on the Key tab. An answer key will print on a separate page after the last page 

of the test if the “Show answer key” box appearing on the Key tab is checked.  

ii) Check the desired boxes on the Key tab to display the additional information you 

would like to see on the answer key.  
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iii) Be sure to enter the number of columns (1-5) you would like on the answer key. 

Multiple columns work best when the test contains all or mostly multiple choice or 

true/false. If the answers are wider than the space allowed by the column the answers will 

wrap within the column.  

iv) Various descriptors can also be selected to print on the answer key from the 

descriptors tab. Those descriptors that are unavailable for the test items you have chosen 

will be grayed out. 

 

Note: Only Paper Tests will display an answer key. If the Test Option Key tab is not 

available, then it may be that the test has been set to a Web Test vs. Paper Test. Open 

the test in the right-hand window of TestGen. Click on the test highlighting an area of 

the test form. Then go to File > Change test type. Select Paper. 

 
 

b.   Test print settings  

i)  To control how multiple forms of the test are presented, make sure the test window 

is active and then select “Print” from the File menu to display the Test Print Settings 

dialog.  

ii) You can use the Test Print Settings dialog to print up to 25 different forms or      

versions of the same test. Each printed version of a test is distinguished by a unique letter 

that is printed as part of the page number (A,B,C…).  

iii) After the initial test form ‘A’, the question order will be scrambled unless you       

choose otherwise. 
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   iv) You can print a correlation guide for question used on the test. This gives the               

 testbank question number and the corresponding question number for each form of the  

 test. 

 

 
 

c.   Reference copy of a test 

i)   To print a reference copy of a test to use when reviewing the test with students,  

display the answers and descriptors, such as answer rationales, on the test. You can 

display the desired information by choosing Preferences > Test Options on the  

Tools menu and selecting the Descriptors tab. Mark the boxes for Correct Answer  

and Explanation. Also, on the Key tab, uncheck "Show answer key" and click OK. 

Then print the reference copy of the test. 

 

5. Exporting Tests to Text, RTF and PDF files 

 
Tests can be exported to various formats by making the appropriate selection from the 

‘Export Test’ menu.  

 

a.   Exporting to Plain Text Files 

i)  You can open plain text files with most word processors. Whenever you export a file 

as a plain text file, it loses all formatting such as bold, underlining, italics, variable text or 

numbers, and graphics. 

 

b.   Exporting Tests to Formatted Text Files 

i)  Use the formatted text file option to export to an .rtf file that you can open with 

Microsoft Word®. 

ii) A test exported to a Formatted Text File produces an rtf, or "rich text," file that 

preserves TestGen's styles such as bold, italics, underline, superscripts, subscripts, color, 

indents, and strikeouts, with the exception of overlines, all lowercase, and boxed styles. 

See TestGen’s help files for more detailed instructions. 

 

 

 

c.   Exporting Tests to Easy Edit Text Files 
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i)  A test exported to an Easy Edit Text File produces an rtf, or "rich text," file that is 

similar to the layout of a Formatted Text File, but does not have all the column and 

section breaks. It is easier to make more extensive changes without causing the rest of the 

page to shift out of alignment. Easy Edit Text files can be opened with most word 

processors for further editing. 

 

d.   Exporting Tests to PDF Files 

i)  You can export any TestGen test to a single PDF file that can be viewed on Windows 

or Macintosh computers using Adobe Acrobat Reader 6.0 or later. When you have a test 

open, select "Export" from the File menu, select PDF, and click OK. When the file dialog 

appears, name the file and save it in the location of your choice. To view the file, double-

click it or open it from Acrobat Reader. 

 

e.   Alternative for Exporting Tests to PDF Files for Macintosh 

i)  The Macintosh operating system has built-in support for saving documents in PDF 

format. With a test open, select "Print" from the TestGen File menu. Then click the Save 

as PDF… button. Enter a filename and click OK. This method works for testbanks and 

any other document that you can print. 

Note: Getting Acrobat Reader - If you do not have a copy of Adobe Reader or need to 

update to a newer version, go to the Adobe web site (get.adobe.com/reader/) and follow 

the links to download the free software. 

6. Exporting Tests to Blackboard 
 

a.   Exporting Tests for Blackboard 

i)   Follow these steps to create a test in TestGen and transfer it into Blackboard 6.x-9.x.  

ii)  On TestGen's Startup screen, click Web Test. Then choose the option for Blackboard 

and click OK. Create the test, whether choosing questions from a testbank or adding your 

own questions. 

iii)  Select "Export" from the File menu, then select the option for Blackboard from the 

Export Test dialog, and click OK. 

iv) Enter a name for the question pool (description is optional), then click OK. Review 

the filename and destination where the .zip file will be created and saved. (By default, the 

name matches its original .TST file and the location is the "tests" folder inside the 

TestGen folder.) You can change either of these, but note that you will need to locate this 

file for the upload process into Blackboard.  Click Save. 

 

b.  Upload the Test into Blackboard 

i)  Log into your Blackboard server.  Click on the Courses tab in the top navigation bar.  

Click the course name that you would like to upload your test questions into.  Click the 

Control Panel button in the left navigation bar. Click Pool Manager in the Assessment 

area or Pools in the Tests, Surveys, and Pools area. This is the area that your tests will be 

imported into. Having existing questions in this area will not affect the import.  Click the 

Import Pool button on the Pool Manager page.  
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ii) Locate the .zip file to upload by clicking the Browse button. (Tip: It may be in the 

"tests" folder inside the TestGen folder.) Then click Open. The .zip file name and 

location display in the box next to the Browse button. Click the Submit button. 

Depending on the number of questions being imported, it may take several minutes for 

the entire question pool import to be transferred into your Blackboard course. A message 

displays when the process is complete. 

 

c.   Create Assessment in Blackboard 

i) The question pool you authored in TestGen can now be used in the same manner as 

question pools created directly within the Blackboard course. 

 

7. Exporting Tests for Desire2Learn 

Follow these steps to create a test in TestGen and transfer it into the Desire2Learn learning 

management system (LMS) as a quiz. 

a.   Choose the Desire2Learn Test Type and Create a Test 

 i)  Select "New test" from the File menu. On the Startup screen, click Web Test. Then 

choose the Desire2Learn option and click OK.  

ii) Create the test, whether choosing from a testbank or adding your own questions. 

 

b.   Export the Test from TestGen as a .Zip File 

i)  Select "Export" from the File menu, select the Desire2Learn option from the drop-

down menu, and click OK. 

ii)  Save the test export file as a zip file. Review the filename and destination where the 

.zip file will be saved. (By default, the name matches its original .TST file and the 

location is the TestGen "Tests" folder.) You can change the destination, if desired, but 

note that you will later need to locate the file during the import process into 

Desire2Learn.  

 

c.   Import the Test into Desire2Learn 

i)   Log in on your Desire2Learn LMS and navigate to your course. 

ii)  Select "Edit." Then select "Import/Export/Copy Components." 

iii) Choose "Import Components" and locate the .zip file that you exported from TestGen. 

iv) Click "Start" and follow the instructions on the screen. The questions will import as a 

Quiz. 

 

Note: The import instructions for Desire2Learn reflect the established process at the time 

the Quick Reference Guide was published. It is subject to change.  

8.   Exporting Tests for Moodle 

Follow these steps to create a test in TestGen and transfer it into the Moodle learning 

management system (LMS) as a question bank. 
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 a.  Choose the Moodle Test Type and Create a Test 

 i)   Select "New test" from the File menu. On the Startup screen, click Web Test.   

Then choose the Moodle option and click OK. 

ii)  Create the test, whether choosing from a testbank or adding your own questions. 

 

     b.  Export the Test from TestGen as an .XML File  
          i)  Select "Export" from the File menu, select the Moodle option from the drop-down 

          menu, and click OK. 

          ii) Save the test export file as an .xml file. Review the filename and destination     

         where the .xml file will be saved. (By default, the name matches its original .TST       

         file and the saved location is the TestGen "Tests" folder.) You can change the  

         destination, if desired, but note that you will later need to locate the file during the  

         import process into Moodle. 

 

    c.  Import the Test into Moodle 

          i)  Log in on your Moodle system and navigate to your course. 

         ii) Under "Course Administration" choose "Question Bank" and then choose   

         "Import." 

         iii) On the Import page, select "Moodle XML format" and locate the .xml file you   

         exported from TestGen. 

         iv) The test will be imported into the Question Bank with a category name that is  

         the same as the test name. 

         v)  Finally, create a quiz from the imported test items in the Question Bank. 

 

Note: The import instructions for Moodle reflect the established process at the time the 

Quick Reference Guide was published. It is subject to change.  

9.   Exporting Tests for Sakai 

Follow these steps to create a test in TestGen and transfer it into the Sakai learning                                                              

management system (LMS) as an assessment. 

      a.  Choose the Sakai Test Type and Create a Test 

           i)  Select "New test" from the File menu. On the Startup screen, click Web Test.  

           Then choose the Sakai option and click OK. 

           ii) Create the test, whether choosing from a testbank or adding your own questions. 

 

      b.  Export the Test from TestGen as a .Zip File 

           i)  Select "Export" from the File menu, select the Sakai option from the drop-down 

           menu, and click OK. 

           ii) Save the test export file as a zip file. Review the filename and destination where  

           the .zip file will be saved. (By default, the name matches its original .TST file and  

           the saved location is the TestGen "Tests" folder.) You can change the destination, if  

           desired, but note that you will later need to locate the file during the import process  

           into Sakai.  
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     c.   Import the Test into Sakai 

           i)   Log in on your Sakai LMs and navigate to your course. 

           ii)  Select the "Test and Quizzes" option. 

           iii) Select "Import." 

           iv) Click "Choose File" and locate the .zip file for the test you exported.  

           v)  Select "Export from this (or other Sakai) system" (should be the default) 

           vi) Click "Import" to import the test questions as an assessment in Sakai. 

 

Note: The import instructions for Sakai reflect the established process at the time the 

Quick Reference Guide was published. It is subject to change.  

 

10.  Math Tools, Graphs and Function Plots 

 
a. Math symbols, fractions, and other computational items. 

 i)  Make sure the equation tool bar is visible. Go to View, then Toolbars, and select 

Equation Toolbar. 

 
ii)  The leftmost group of Toolbar icons allow the insertion of special symbols. The 

rightmost group of icons allow the insertion of templates.  

ii) Left click one of the tool bar icons and then left click one of the icons in the pop up 

palette. Either the symbol will be inserted or, in the case of templates, boxes will appear 

for adding numbers/values. 

 

b. Figures can be added to test questions or answers.  

i) Save the figure on your hard drive 

ii) In the appropriate question or answer, choose Insert, then Picture. Find and open the  

file and the image will appear in the question. You can also drag the graphic file onto the 

desired field and it will be inserted at the last cursor position. 

iii) Graphics can be placed as a text character or as a transparent graphic. If placed as a 

text character it will move based on tabs, returns, and other objects just like a large text 

character. If placed as a transparent graphic then text and graphics can be layered over the 

graphic. 

 

       c.   Function plots can be added to test questions or answers.  

   i)  Go to Insert, then graph, and select Cartesian, Polar, or Number Line. 

 ii)  In the pop up window, use the format button to set the details of axes and grid.   Use 

the graph button to add the functions to plot. You can resize the graph by changing the 

window dimensions or by double clicking the graph. 

iii) Use the place button to put the function plot into the test. It can be reopened for 

editing by double clicking the function plot in the test. 
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